The Weekly Herald

scie and axsee's electronics weblog.
<< 車載加速度アナログメータ2 | main | グラフィックLCDモジュール ハードウェア編 >>
スポンサーサイト このエントリーを含むはてなブックマーク

一定期間更新がないため広告を表示しています

| 書いた人:スポンサードリンク | - | | - | -
車載加速度アナログメータ3 このエントリーを含むはてなブックマーク
メータ部分の構想はだいたいまとまってきたので、次は肝心の加速度センサの部分。
使用する部品は秋月電子で購入したKXM52-1050
このパーツはあらかじめ基板にセンサが実装されていてパスコンなども搭載されている。
電源と出力といくつかのピンが出ているだけなので、案外簡単そうだと思った。
でも加速度センサは初めて使う素子なので、どうやって使うかよく仕様書を読まないと。
仕様書2秋月付属の仕様書を読んでいくとピンの説明の欄には、
パリティ端子 ⇒ 無接続
セルフテスト端子 ⇒ GNDに接続
と書いてある。

仕様書1なるほどー。親切に使うときの方法も書いてあるなぁと思いながら使い方の欄をみると、
パリティ端子 ⇒ GNDに接続
セルフテスト端子 ⇒ 無接続
と書いてある・・・あせあせ
どっちが正しいんだ

仕方なくインターネットで調べてみると、どうもピン説明のところに書いてあるように、
パリティ端子 ⇒ 無接続
セルフテスト端子 ⇒ GNDに接続
とするのが正しいらしい。
まぎらわしい。

ハードウェアの使い方はだいたいわかったので、実際に出力に前の実験で使用したアナログメータを繋いでみた。
仕様書的には加速度センサの出力値は0[G]時、Vdd / 2[V]の電圧が出力されてくるはずだ。
今回はZ軸(垂直方向)の端子をつなげたので1[G]の加速度がかかっている。
センサの電源電圧は5[V]。
予想では最低でも2.5[V]以上出力されるはずと思った。
が・・・
メータは2[V]の値を指している。
あれ?
おかしいと思い、VddとGNDにテスタをあててみたが確かに5[V]入力されている。
出力にテスターをあてると、テスタには3.7[V]と表示された。

もう一度仕様書を確認すると出力電流は1.5[mA]と書いている。
どうも電流不足でメータが動かなかったんじゃないかと思った。
それなら、どうせオペアンプで増幅するのだから電流が少ないのは問題ない。
ということで気にせず次の段階へ。

オペアンプはこの前の実験でも使ったので使い方は覚えている。
最初、この前フォトトランジスタの出力を入れていた場所に加速度センサの値を入れてみた。
するとメータは5[V]になったまま、まったく動かない。よく考えてみれば増幅率が11倍だった。
オペアンプの出力が飽和していたのだ。
やはり、他の実験の時に使用した回路をそのまま使うのはよくない。
倍率を4倍にして、オペアンプの電源を12[V]にアップし再実験してみた。
すると、メータは重力方向(1G)にセンサを置くと12[V]になった。そして重力と垂直の方向(0G)に加速度センサを傾けるとメータは9[V]になった。
理論値とは少し違うが、まずまずの結果となった。
これはそのときの動画です。

これで各部品の実験はおおむね終了。
あとはもう少しセンサの実験をしたあと、車載に向けて完成させるのみです。
動作中の動画
| 書いた人:axsee | Car | 01:49 | comments(0) | trackbacks(0)
スポンサーサイト このエントリーを含むはてなブックマーク
| 書いた人:スポンサードリンク | - | 01:49 | - | -
コメント
コメントする
※コメント欄にHTMLタグを使用することはできません。
※コメント欄内のURLは、自動的にリンクへと変換されます。
※英数字のみのコメントは投稿できません。









この記事のトラックバックURL
http://herald.jugem.jp/trackback/57
トラックバック
     12
3456789
10111213141516
17181920212223
24252627282930
<< September 2017 >>


ブログ カウンター岩盤浴ゲルマニウム温浴